WordPress plugin · frontend-dashboard
Is Frontend Dashboard safe?
Safe on 3.1.0 or newer.
The current version, 3.1.0, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 8
- Exploited
- none
- Current version
- 3.1.0
- Last updated
- Oct 29, 2026
- Active installs
- 500+
Every recorded flaw
- Oct 14, 2026Frontend Dashboard: Incorrect Privilege AssignmentCVE-2026-107424 · affects up to 3.0.7 · reported by PatchstackCritical 9.8
- Oct 8, 2026Frontend Dashboard: Does not perform any authorisation or nonce check on actions available to unauthenticated users that call an attacker-chosen PHP function or class method with the request dataCVE-2026-103692 · fixed in 3.0.5 · reported by WPScanCritical 9.8
- Oct 7, 2026Frontend Dashboard: Does not perform a capability check in one of its AJAX actionsCVE-2026-103681 · fixed in 3.0.0 · reported by WPScanMedium 4.3
- Jun 6, 2025Frontend Dashboard: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49310 · affects up to 2.2.8 · reported by PatchstackMedium 6.5
- May 13, 2025Frontend Dashboard: Privilege EscalationCVE-2025-4474 · affects 1.0 to 2.2.7 · reported by WordfenceHigh 8.8
- May 13, 2025Frontend Dashboard: Privilege EscalationCVE-2025-4473 · affects 1.0 to 2.2.7 · reported by WordfenceHigh 8.8
- May 7, 2025Frontend Dashboard: Privilege EscalationCVE-2025-4104 · affects 1.0 to 2.2.6 · reported by WordfenceCritical 9.8
- Apr 24, 2025Frontend Dashboard: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-46248 · affects up to 2.2.5 · reported by PatchstackCritical 9.3
- Sep 9, 2024Frontend Dashboard: Unauthorized code executionCVE-2024-8268 · affects up to 2.2.4 · reported by WordfenceHigh 8.8
- Apr 24, 2024Frontend Dashboard: Exposure of Sensitive Information to an Unauthorized ActorCVE-2024-32726 · affects up to 2.2.2 · reported by PatchstackHigh 7.5
- Mar 27, 2024Frontend Dashboard: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29775 · affects up to 2.2.1 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.