WordPress plugin · buddypress
Is BuddyPress safe?
Safe on 14.5.4 or newer.
The current version, 14.5.4, is past every affected range on record (10 of 14 records list one; 4 don’t, so check those below). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 7
- Exploited
- none
- Current version
- 14.5.4
- Last updated
- Oct 23, 2026
- Active installs
- 90,000+
Every recorded flaw
- Oct 28, 2026BuddyPress: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-111850 · affects up to 14.5.2 · reported by PatchstackHigh 8.5
- Sep 11, 2026BuddyPress: Insecure Direct Object ReferenceCVE-2024-12145 · affects up to 14.3.3 · reported by WordfenceMedium 4.3
- Jul 31, 2026BuddyPress: Does not properly enforce authorization on its private messaging endpointsCVE-2026-8155 · fixed in 14.5.0 · reported by WPScanMedium 5.4
- Jul 30, 2026BuddyPress: Deserialization of Untrusted DataCVE-2026-1360 · affects up to 14.5.0 · reported by Wordfence1.2% oddsHigh 7.5
- Jun 9, 2026the friends REST API that: BuddyPress 14.4.0 contains an insecure direct object referenceCVE-2026-53675 · reported by VulnCheckMedium 5.3
- Jun 9, 2026the activity mention resolver that, when username compatibility mode is enabled,: BuddyPress 14.4.0 contains a regular expression injectionCVE-2026-53674 · reported by VulnCheckHigh 7.1
- Jun 9, 2026the messages REST API that: BuddyPress 14.4.0 contains an insecure direct object referenceCVE-2026-53673 · reported by VulnCheckHigh 8.6
- May 16, 2026WordPress Plugin Buddypress 6.2.0 contains a persistent cross-site scripting vulnerability that allows authenticated attackers with moderator privileges to injeCVE-2020-37233 · reported by VulnCheckMedium 5.1
- Jan 23, 2026The BuddyPress: Arbitrary shortcode executionCVE-2024-11976 · affects up to 14.3.3 · reported by WordfenceHigh 7.3
- Oct 22, 2025BuddyPress: Missing AuthorizationCVE-2025-62022 · affects up to 14.3.4 · reported by PatchstackHigh 7.5
- Oct 25, 2024BuddyPress: Directory TraversalCVE-2024-10011 · affects up to 14.1.0 · reported by Wordfence1.2% oddsHigh 8.1
- Jun 11, 2024BuddyPress: Stored Cross-Site ScriptingCVE-2024-4892 · affects up to 12.4.1 · reported by WordfenceMedium 6.4
- May 14, 2024BuddyPress: Stored Cross-Site ScriptingCVE-2024-3974 · affects up to 12.4.0 · reported by WordfenceMedium 6.4
- Dec 29, 2023BuddyPress: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-50880 · affects up to 11.3.1 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.