WordPress plugin · bookit
Is Bookit safe?
Safe on 2.6.0.7 or newer.
The current version, 2.6.0.7, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 4
- Exploited
- none
- Current version
- 2.6.0.7
- Last updated
- Oct 29, 2026
- Active installs
- 4,000+
Every recorded flaw
- Oct 16, 2026BookIt: Missing AuthorizationCVE-2026-110900 · affects up to 2.6.0.5 · reported by PatchstackMedium 5.3
- Sep 18, 2026Bookit — Booking & Appointment Calendar: Does not perform an authorization check on one of its appointment-retrieval actionsCVE-2026-89008 · fixed in 2.6.0.5 · reported by WPScanLow 2.7
- Sep 18, 2026Bookit — Booking & Appointment Calendar: Does not perform a capability check in one of its appointment-deletion functionsCVE-2026-89007 · fixed in 2.6.0.5 · reported by WPScanLow 2.7
- Sep 13, 2026Bookit — Booking & Appointment Calendar: Does not properly restrict the data returned by an availability-check requestCVE-2026-88995 · fixed in 2.6.0.1 · reported by WPScanMedium 5.3
- Sep 3, 2026Unauthenticated Bypass Vulnerability in BookIt <= 2.6.0.3 versions.CVE-2026-84767 · affects up to 2.6.0.3 · reported by PatchstackMedium 5.3
- Jun 2, 2026BookIt: Authentication Bypass Using an Alternate Path or ChannelCVE-2026-40780 · fixed in 2.5.4.1 · reported by PatchstackHigh 7.5
- Dec 12, 2025Bookit: Has a publicly accessible REST endpoint that allows unauthenticated update of the plugins Stripe payment optionsCVE-2025-12841 · fixed in 2.5.1 · reported by WPScanMedium 5.3
- Nov 12, 2025Booking Calendar | Appointment Booking | Bookit: Unauthorized modification of dataCVE-2025-12633 · affects up to 2.5.0 · reported by WordfenceHigh 7.5
- May 17, 2024BookIt: Improper Validation of Specified Quantity in InputCVE-2024-24715 · affects up to 2.4.0 · reported by PatchstackMedium 6.5
- Dec 28, 2023Booking Calendar | Appointment Booking | BookIt: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2023-50852 · affects up to 2.4.3 · reported by PatchstackHigh 7.6
- Jun 29, 2023BookIt: Authentication bypassCVE-2023-2834 · affects up to 2.3.7 · reported by Wordfence1.9% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.