WordPress plugin · backup
Is JetBackup safe?
Safe on 3.1.24.10 or newer.
The current version, 3.1.24.10, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 4
- Exploited
- none
- Current version
- 3.1.24.10
- Last updated
- Oct 18, 2026
- Active installs
- 200,000+
Every recorded flaw
- Oct 22, 2026JetBackup: Symlink-based arbitrary file writeCVE-2026-104068 · fixed in 3.1.24.10 · reported by VulnCheckHigh 8.6
- Sep 2, 2026JetBackup: Does not verify the role or capabilities of the account it preserves across a restore or migration before granting it administrator privilegesCVE-2026-19453 · fixed in 3.1.23.5 · reported by WPScanHigh 7.1
- Aug 27, 2026JetBackup: Does not perform its multisite authorisation check before serving backup archives and job logsCVE-2026-19454 · fixed in 3.1.23.5 · reported by WPScanMedium 4.4
- Apr 17, 2026JetBackup – Backup, Restore & Migrate: Path Traversal leading to Arbitrary Directory DeletionCVE-2026-4853 · affects up to 3.1.19.8 · reported by WordfenceMedium 4.9
- Feb 27, 2024JetBackup: Doesn't use index files to prevent public directory listing of sensitive directories in certain configurationsCVE-2023-7165 · fixed in 2.0.9.9 · reported by WPScan1.9% oddsHigh 7.5
- Mar 15, 2023Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in JetBackup JetBackup – WP Backup, Migrate & Restore plugin CVE-2022-34148 · affects up to 1.6.9.0 · reported by PatchstackMedium 4.8
- Mar 7, 2023JetBackup – WP Backup, Migrate & Restore: Cross-Site Request ForgeryCVE-2020-36669 · affects up to 1.3.9 · reported by WordfenceHigh 8.8
- Mar 7, 2023JetBackup – WP Backup, Migrate & Restore: Sensitive information disclosureCVE-2020-36668 · affects up to 1.4.0 · reported by WordfenceMedium 4.3
- Mar 7, 2023JetBackup – WP Backup, Migrate & Restore: Unauthorized back-up location changesCVE-2020-36667 · affects up to 1.4.1 · reported by WordfenceMedium 5.4
- Aug 13, 2019The Backup Guard plugin before 1.1.47 for WordPress has multiple XSS issues.CVE-2017-18488 · fixed in 1.1.47 · reported by MITREMedium 6.1
- Aug 28, 2017BackupGuard prior to version 1.1.47: Cross-site scriptingCVE-2017-10837 · affects up to 1.1.46 · reported by vultures@jpcert.or.jpMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.