WordPress plugin · awesome-support
Is Awesome Support safe?
Safe on 6.4.2 or newer.
The current version, 6.4.2, is past every affected range on record (30 of 30 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 30
- High or critical
- 6
- Exploited
- none
- Current version
- 6.4.2
- Last updated
- Oct 16, 2026
- Active installs
- 6,000+
Every recorded flaw
- Oct 28, 2026Awesome Support – WordPress HelpDesk & Support: Stored Cross-Site ScriptingCVE-2026-103370 · affects up to 6.4.1 · reported by WordfenceMedium 6.4
- Oct 1, 2026Awesome Support – WordPress HelpDesk & Support: Stored Cross-Site ScriptingCVE-2026-96268 · affects up to 6.4.0 · reported by WordfenceMedium 6.4
- Sep 30, 2026Subscriber Cross Site Scripting (XSS) in Awesome Support <= 6.3.9 versions.CVE-2026-96820 · affects up to 6.3.9 · reported by PatchstackHigh 7.1
- Sep 9, 2026Awesome Support: Missing AuthorizationCVE-2026-19946 · affects up to 6.3.9 · reported by WordfenceMedium 4.3
- Apr 8, 2026Awesome Support – WordPress HelpDesk & Support: Insecure Direct Object ReferenceCVE-2026-4654 · affects up to 6.3.7 · reported by WordfenceMedium 5.3
- Jan 16, 2026Awesome Support - WordPress HelpDesk & Support: Authorization bypassCVE-2025-12641 · affects up to 6.3.6 · reported by WordfenceMedium 6.5
- Sep 22, 2025Awesome Support: Deserialization of Untrusted DataCVE-2025-58662 · affects up to 6.3.5 · reported by PatchstackHigh 7.2
- Sep 9, 2025Awesome Support: Missing AuthorizationCVE-2025-53340 · affects up to 6.3.6 · reported by PatchstackMedium 5.3
- Apr 1, 2025Awesome Support – WordPress HelpDesk & Support: Sensitive Information ExposureCVE-2024-13567 · affects up to 6.3.1 · reported by WordfenceHigh 7.5
- Dec 13, 2024Awesome Support: Missing AuthorizationCVE-2024-54289 · affects up to 6.3.1 · reported by PatchstackMedium 6.5
- Dec 9, 2024Awesome Support: Missing AuthorizationCVE-2023-49857 · affects up to 6.1.7 · reported by PatchstackMedium 6.5
- Dec 9, 2024Awesome Support: Missing AuthorizationCVE-2023-49757 · affects up to 6.1.10 · reported by PatchstackMedium 5.4
- Dec 9, 2024Awesome Support: Missing AuthorizationCVE-2023-48324 · affects up to 6.1.4 · reported by PatchstackMedium 5.4
- Jun 12, 2024Awesome Support: Missing AuthorizationCVE-2023-51537 · affects up to 6.1.5 · reported by PatchstackMedium 5.3
- Jun 10, 2024Awesome Support: Missing AuthorizationCVE-2024-35741 · affects up to 6.1.7 · reported by PatchstackMedium 4.3
- Jun 9, 2024Awesome Support: Missing AuthorizationCVE-2024-24716 · affects up to 6.1.6 · reported by PatchstackMedium 5.4
- Jun 9, 2024Awesome Support: Missing AuthorizationCVE-2024-30539 · affects up to 6.1.7 · reported by PatchstackMedium 5.3
- Feb 10, 2024Awesome Support – WordPress HelpDesk & Support: Unauthorized access of dataCVE-2024-0596 · affects up to 6.1.7 · reported by WordfenceMedium 5.3
- Feb 10, 2024Awesome Support – WordPress HelpDesk & Support: Unauthorized accessCVE-2024-0595 · affects up to 6.1.7 · reported by WordfenceMedium 4.3
- Feb 10, 2024Awesome Support – WordPress HelpDesk & Support: Union-based SQL InjectionCVE-2024-0594 · affects up to 6.1.7 · reported by WordfenceHigh 8.8
- Jan 5, 2024Awesome Support – WordPress HelpDesk & Support: Cross-Site Request Forgery (CSRF)CVE-2023-51538 · affects up to 6.1.5 · reported by PatchstackMedium 4.3
- Nov 30, 2023Awesome Support – WordPress HelpDesk & Support: Cross-Site Request Forgery (CSRF)CVE-2023-48323 · affects up to 6.1.4 · reported by PatchstackMedium 4.3
- Nov 6, 2023Awesome Support: Does not sanitize file pathsCVE-2023-5355 · fixed in 6.1.5 · reported by WPScanHigh 8.1
- Nov 6, 2023Awesome Support: Does not sanitise and escape a parameter before outputting it back in the pageCVE-2023-5354 · fixed in 6.1.5 · reported by WPScanMedium 6.1
- Nov 6, 2023Awesome Support: Does not correctly authorize the wpas_edit_reply functionCVE-2023-5352 · fixed in 6.1.5 · reported by WPScanMedium 4.3
- Nov 28, 2022Awesome Support: Does not ensure that the exported tickets archive to be downloaded belongs to the user making the requestCVE-2022-3511 · fixed in 6.1.2 · reported by WPScanMedium 6.5
- Sep 21, 2022Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.CVE-2022-38073 · affects up to 6.0.7 · reported by PatchstackMedium 5.4
- Nov 26, 2021Multiple Authenticated Reflected Cross-Site Scripting (XSS) vulnerabilities in WordPress Awesome Support plugin (versions <= 6.0.6), vulnerable parameters (&id,CVE-2021-36919 · affects up to 6.0.6 · reported by PatchstackMedium 6.1
- Aug 20, 2019The awesome-support plugin before 3.1.7 for WordPress has a security issue in which shortcodes are allowed in replies.CVE-2015-9318 · fixed in 3.1.7 · reported by MITRE1.4% oddsHigh 7.5
- Aug 20, 2019The awesome-support plugin before 3.1.7 for WordPress has XSS via custom information messages.CVE-2015-9317 · fixed in 3.1.7 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.