WordPress plugin · ajax-search-lite
Is Ajax Search Lite safe?
Safe on 4.14.7 or newer.
The current version, 4.14.7, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 4
- Exploited
- none
- Current version
- 4.14.7
- Last updated
- Oct 19, 2026
- Active installs
- 70,000+
Every recorded flaw
- Oct 21, 2026Ajax Search Lite: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-111852 · affects up to 4.14.6 · reported by PatchstackCritical 9.3
- Oct 15, 2026Ajax Search Lite: Missing AuthorizationCVE-2026-110360 · affects up to 4.14.5 · reported by PatchstackMedium 5.3
- Aug 7, 2026Ajax Search Lite: Does not prevent the deserialization of untrusted inputCVE-2026-16258 · fixed in 4.14.5 · reported by WPScanCritical 9.8
- Aug 6, 2026Unauthenticated PHP Object Injection in Ajax Search Lite <= 4.14.4 versions.CVE-2026-28139 · affects up to 4.14.4 · reported by PatchstackCritical 9.8
- Nov 6, 2025Ajax Search Lite: Deserialization of Untrusted DataCVE-2025-48086 · affects up to 4.13.3 · reported by PatchstackMedium 5.5
- Aug 28, 2025Ajax Search Lite: Basic Information ExposureCVE-2025-7956 · affects up to 4.13.1 · reported by WordfenceMedium 5.3
- May 15, 2025Ajax Search Lite: Does not sanitise and escape some of its settingsCVE-2024-8619 · fixed in 4.12.3 · reported by WPScanMedium 4.8
- Feb 21, 2025Ajax Search Lite: Does not sanitise and escape some of its settingsCVE-2024-13585 · fixed in 4.12.5 · reported by WPScanLow 3.5
- Dec 12, 2024Ajax Search Lite: Does not sanitise and escape some of its settingsCVE-2024-10568 · fixed in 4.12.4 · reported by WPScanMedium 4.7
- Aug 6, 2024Ajax Search Lite: Does not sanitise and escape some parametersCVE-2024-7084 · fixed in 4.12.1 · reported by WPScanMedium 4.8
- Feb 29, 2024Ajax Search Lite: Cross-Site Request Forgery (CSRF)CVE-2024-21752 · affects up to 4.11.4 · reported by PatchstackHigh 7.1
- Mar 15, 2023Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Ernest Marcinko Ajax Search Lite plugin <= 4.10.3 versions.CVE-2022-38456 · affects up to 4.10.3 · reported by PatchstackMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.