Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
4 results
Nov 11, 2020touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting (XSS).CVE-2020-26221 · Other software · puncsky · reported by GitHubHigh 8
touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting (XSS). The vulnerability allows an attacker to send malicious JavaScript code which could result in hijacking of the user's cookie/session tokens, redirecting the user to a malicious webpage and performing unintended browser action. The issue is patched in version 2.0.
- Product
- touchbase.ai
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Nov 11, 2020toucbase.ai before version 2.0 leaks information by not stripping exif data from images.CVE-2020-26220 · Other software · puncsky · reported by GitHubLow 3.5
toucbase.ai before version 2.0 leaks information by not stripping exif data from images. Anyone with access to the uploaded image of other users could obtain its geolocation, device, and software version data etc (if present. The issue is fixed in version 2.0.
- Product
- touchbase.ai
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Nov 11, 2020touchbase.ai before version 2.0 is vulnerable to Open Redirect.CVE-2020-26219 · Other software · puncsky · reported by GitHubMedium 4.7
touchbase.ai before version 2.0 is vulnerable to Open Redirect. Impacts can be many, and vary from theft of information and credentials, to the redirection to malicious websites containing attacker-controlled content, which in some cases even cause XSS attacks. So even though an open redirection might sound harmless at first, the impacts of it can be severe should it be exploitable. The issue is fixed in version 2.0.
- Product
- touchbase.ai
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Nov 11, 2020touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting.CVE-2020-26218 · Other software · puncsky · reported by GitHubHigh 8
touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting. The vulnerability allows an attacker to inject HTML payloads which could result in defacement, user redirection to a malicious webpage/website etc. The issue is patched in version 2.0.
- Product
- touchbase.ai
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.