Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 8 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
343new WordPress flaws this week
390,080entries in the database

7 results

  • Jul 23, 2025LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces.CVE-2025-53537 · Other software · OISF · reported by GitHubHigh 7.5

    LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set `suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled` to false. This issue is fixed in version 0.5.51.

    Product
    libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Oct 16, 2024LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces.CVE-2024-45797 · Other software · OISF · reported by GitHubHigh 7.5

    LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Prior to version 0.5.49, unbounded processing of HTTP request and response headers can lead to excessive CPU time and memory utilization, possibly leading to extreme slowdowns. This issue is addressed in 0.5.49.

    Product
    libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 4, 2024LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces.CVE-2024-28871 · Other software · OISF · reported by GitHubHigh 7.5

    LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.

    Product
    libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 26, 2024LibHTP is a security-aware parser for the HTTP protocol.CVE-2024-23837 · Other software · OISF · reported by GitHubHigh 7.5

    LibHTP is a security-aware parser for the HTTP protocol. Crafted traffic can cause excessive processing time of HTTP headers, leading to denial of service. This issue is addressed in 0.5.46.

    Product
    libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Oct 9, 2019In OISF LibHTP before 0.5.31, as used in Suricata 4.1.4 and other products, an HTTP protocol parsing error causes the http_header signature to not alert on a reCVE-2019-17420 · Other software · Oisf · reported by MITREMedium 5.3

    In OISF LibHTP before 0.5.31, as used in Suricata 4.1.4 and other products, an HTTP protocol parsing error causes the http_header signature to not alert on a response with a single \r\n ending.

    Product
    Libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 4, 2019htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest headCVE-2018-10243 · Other software · Oisf · reported by MITRECritical 9.8

    htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.

    Product
    Libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Aug 28, 2017libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).CVE-2015-0928 · Other software · Oisf · reported by cret@cert.orgHigh 7.5

    libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

    Product
    Libhtp
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.