Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 8 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
343new WordPress flaws this week
390,080entries in the database

8 results

  • Oct 23, 2026MongoDB Compass relies on Electron, a third-party runtime that carries its own TLS root certificate store.CVE-2026-115929 · Other software · MongoDB, Inc. · reported by cna@mongodb.comHigh 7.6

    MongoDB Compass relies on Electron, a third-party runtime that carries its own TLS root certificate store. This root certificate store has the recoverable eMudhra intermediate CA certificates. Issue is resolved by updating to Compass 1.53.1, which includes Electron 44.9.1.

    Product
    Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Oct 21, 2026MongoDB Compass improperly escapes certain BSON values when converting a stored view’s aggregation pipeline into editable source.CVE-2026-113870 · Other software · MongoDB · reported by cna@mongodb.comHigh 8.6

    MongoDB Compass improperly escapes certain BSON values when converting a stored view’s aggregation pipeline into editable source. When a user connects to a MongoDB deployment containing a specially crafted view and opens that view for editing, the values can cause arbitrary code to execute with the privileges of the user running Compass.

    Product
    Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Sep 24, 2026MongoDB Compass can interpolate a database name without escaping into the initial input of its embedded MongoDB shell when a user opens the shell from that dataCVE-2026-96750 · Other software · MongoDB · reported by cna@mongodb.comHigh 7.3

    MongoDB Compass can interpolate a database name without escaping into the initial input of its embedded MongoDB shell when a user opens the shell from that database's view. A user with privileges to create databases on a server that a Compass user connects to may, under specific conditions, have content evaluated as shell input within the Compass process, with that process's privileges. This requires the Compass user to open the shell for the affected database.

    Product
    Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jul 22, 2026When importing connections in Compass it is possible to override some connection options that are otherwise can't be changed via connection form.CVE-2026-14881 · Other software · MongoDB · reported by cna@mongodb.comHigh 8.4

    When importing connections in Compass it is possible to override some connection options that are otherwise can't be changed via connection form. In particular it is possible to provide a custom browser open command for OIDC auth flow that is usually can be set only globally via Compass settings.

    Product
    MongoDB Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 27, 2025MongoDB Compass may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevCVE-2025-1755 · Other software · MongoDB Inc · reported by cna@mongodb.comHigh 7.5

    MongoDB Compass may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privileges, when a crafted file is stored in C:\node_modules\. This issue affects MongoDB Compass prior to 1.42.1

    Product
    MongoDB Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jul 1, 2024MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connectionCVE-2024-6376 · Other software · MongoDB Inc · reported by cna@mongodb.comHigh 7

    MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2

    Product
    MongoDB Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 24, 2024MongoDB Compass may accept and use insufficiently validated input from an untrusted external source.CVE-2024-3371 · Other software · MongoDB Inc · reported by cna@mongodb.comHigh 7.1

    MongoDB Compass may accept and use insufficiently validated input from an untrusted external source. This may cause unintended application behavior, including data disclosure and enabling attackers to impersonate users. This issue affects MongoDB Compass versions 1.35.0 to 1.42.0.

    Product
    MongoDB Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 6, 2021A malicious 3rd party with local access to the Windows machine where MongoDB Compass is installed can execute arbitrary software with the privileges of the userCVE-2021-20334 · Other software · MongoDB Inc. · reported by cna@mongodb.comMedium 4.8

    A malicious 3rd party with local access to the Windows machine where MongoDB Compass is installed can execute arbitrary software with the privileges of the user who is running MongoDB Compass. This issue affects: MongoDB Inc. MongoDB Compass 1.x version 1.3.0 on Windows and later versions; 1.x versions prior to 1.25.0 on Windows.

    Product
    MongoDB Compass
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.