Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 36 min ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,766exploited flaws on CISA’s list
37added in the last 30 days
544new WordPress flaws this week
391,181entries in the database

59 results · page 2 of 2

  • Jul 30, 2021In Charm 0.43, any two users can collude to achieve the ability to decrypt YCT14 data.CVE-2021-37588 · Other software · JHU · reported by MITREMedium 5.9

    In Charm 0.43, any two users can collude to achieve the ability to decrypt YCT14 data.

    Product
    Charm
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jul 30, 2021In Charm 0.43, any single user can decrypt DAC-MACS or MA-ABE-YJ14 data.CVE-2021-37587 · Other software · JHU · reported by MITREMedium 6.5

    In Charm 0.43, any single user can decrypt DAC-MACS or MA-ABE-YJ14 data.

    Product
    Charm
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • May 11, 2021In JetBrains PyCharm before 2020.3.4, local code execution was possible because of insufficient checks when getting the project from VCS.CVE-2021-30005 · Other software · Jetbrains · reported by MITREHigh 7.8

    In JetBrains PyCharm before 2020.3.4, local code execution was possible because of insufficient checks when getting the project from VCS.

    Product
    Pycharm
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 21, 2020DBdeployer is a tool that deploys MySQL database servers easily.CVE-2020-26277 · Other software · datacharmer · reported by GitHubMedium 6.1

    DBdeployer is a tool that deploys MySQL database servers easily. In DBdeployer before version 1.58.2, users unpacking a tarball may use a maliciously packaged tarball that contains symlinks to files external to the target. In such scenario, an attacker could induce dbdeployer to write into a system file, thus altering the computer defenses. For the attack to succeed, the following factors need to contribute: 1) The user is logged in as root. While dbdeployer is usable as root, it was designed to run as unprivileged user. 2) The user has taken a tarball from a non secure source, without testing the checksum. When the tarball is retrieved through dbdeployer, the checksum is compared before attempting to unpack. This has been fixed in version 1.58.2.

    Product
    dbdeployer
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 10, 2020In JetBrains PyCharm 2019.2.5 and 2019.3 on Windows, Apple Notarization Service credentials were included.CVE-2020-11694 · Other software · Jetbrains · reported by MITREHigh 7.5

    In JetBrains PyCharm 2019.2.5 and 2019.3 on Windows, Apple Notarization Service credentials were included. This is fixed in 2019.2.6 and 2019.3.3.

    Product
    Pycharm
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Oct 2, 2019JetBrains PyCharm before 2019.2 was allocating a buffer of unknown size for one of the connection processes.CVE-2019-14958 · Other software · Jetbrains · reported by MITREHigh 7.5

    JetBrains PyCharm before 2019.2 was allocating a buffer of unknown size for one of the connection processes. In a very specific situation, it could lead to a remote invocation of an OOM error message because of Uncontrolled Memory Allocation.

    Product
    Pycharm
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 22, 2009Unrestricted file upload vulnerability in ofc_upload_image.php in Open Flash Chart v2 Beta 1 through v2 Lug Wyrm Charmer, as used in Piwik 0.2.35 through 0.4.3,CVE-2009-4140 · Other software · Teethgrinder.co.uk · reported by Red HatHigh 7.5

    Unrestricted file upload vulnerability in ofc_upload_image.php in Open Flash Chart v2 Beta 1 through v2 Lug Wyrm Charmer, as used in Piwik 0.2.35 through 0.4.3, Woopra Analytics Plugin before 1.4.3.2, and possibly other products, when register_globals is enabled, allows remote authenticated users to execute arbitrary code by uploading a file with an executable extension through the name parameter with the code in the HTTP_RAW_POST_DATA parameter, then accessing it via a direct request to the file in tmp-upload-images/.

    Product
    Open Flash Chart
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 6, 2009Multiple cross-site scripting (XSS) vulnerabilities in Kipper 2.01 allow remote attackers to inject arbitrary web script or HTML via the charm parameter to (1) CVE-2009-0764 · Other software · Bookelves · reported by MITREMedium 4.3

    Multiple cross-site scripting (XSS) vulnerabilities in Kipper 2.01 allow remote attackers to inject arbitrary web script or HTML via the charm parameter to (1) index.php and (2) kipper.php. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.

    Product
    Kipper
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 6, 2009Cross-site scripting (XSS) vulnerability in default.php in Kipper 2.01 allows remote attackers to inject arbitrary web script or HTML via the charm parameter.CVE-2009-0763 · Other software · Bookelves · reported by MITREMedium 4.3

    Cross-site scripting (XSS) vulnerability in default.php in Kipper 2.01 allows remote attackers to inject arbitrary web script or HTML via the charm parameter.

    Product
    Kipper
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.