By year
17
18
19
20
21
22
23
Bars are flaws published each year; the red part is the share attackers have used.
Exploited Webkitgtk flaws
These are on CISA’s Known Exploited Vulnerabilities list, newest first. If you run any of these products, these come before everything else.
- CVE-2019-8720 WebKitGTK Memory CorruptionExploited since May 23, 2022 · CVSS 8.8
Latest high and critical flaws
- CVE-2023-2203 A flaw was found in the WebKitGTK package.High 8.8 · May 17, 2023
- CVE-2019-8720 WebKitGTK Memory CorruptionExploited · High 8.8 · Mar 6, 2023
- CVE-2023-25363 A use-after-free vulnerability in WebCore::RenderLayer::updateDescendantDependentFlags in WebKitGTK before 2.36.8 allows attackers to execute code remotely.High 8.8 · Mar 2, 2023
- CVE-2023-25362 A use-after-free vulnerability in WebCore::RenderLayer::repaintBlockSelectionGaps in WebKitGTK before 2.36.8 allows attackers to execute code remotely.High 8.8 · Mar 2, 2023
- CVE-2023-25361 A use-after-free vulnerability in WebCore::RenderLayer::setNextSibling in WebKitGTK before 2.36.8 allows attackers to execute code remotely.High 8.8 · Mar 2, 2023
- CVE-2023-25360 A use-after-free vulnerability in WebCore::RenderLayer::renderer in WebKitGTK before 2.36.8 allows attackers to execute code remotely.High 8.8 · Mar 2, 2023
- CVE-2023-25358 A use-after-free vulnerability in WebCore::RenderLayer::addChild in WebKitGTK before 2.36.8 allows attackers to execute code remotely.High 8.8 · Mar 2, 2023
- CVE-2022-30293 In WebKitGTK through 2.36.0 (and WPE WebKit), there is a heap-based buffer overflow in WebCore::TextureMapperLayer::setContentsLayer in WebCore/platform/graphicHigh 7.5 · May 6, 2022
- CVE-2021-21806 An exploitable use-after-free vulnerability exists in WebKitGTK browser version 2.30.3 x64.High 8.8 · Jul 8, 2021
- CVE-2021-21779 A use-after-free vulnerability exists in the way Webkit’s GraphicsContext handles certain events in WebKitGTK 2.30.4.High 8.8 · Jul 8, 2021
- CVE-2021-21775 A use-after-free vulnerability exists in the way certain events are processed for ImageLoader objects of Webkit WebKitGTK 2.30.4.High 8 · Jul 7, 2021
- CVE-2020-13558 A code execution vulnerability exists in the AudioSourceProviderGStreamer functionality of Webkit WebKitGTK 2.30.1.High 8.8 · Mar 3, 2021
- CVE-2020-13584 An exploitable use-after-free vulnerability exists in WebKitGTK browser version 2.30.1 x64.High 8.8 · Dec 3, 2020
- CVE-2020-13543 A code execution vulnerability exists in the WebSocket functionality of Webkit WebKitGTK 2.30.0.High 8.8 · Dec 3, 2020
- CVE-2020-13753 The bubblewrap sandbox of WebKitGTK and WPE WebKit, prior to 2.28.3, failed to properly block access to CLONE_NEWUSER and the TIOCSTI ioctl.Critical 10 · Jul 14, 2020
- CVE-2020-11793 A use-after-free issue exists in WebKitGTK before 2.28.1 and WPE WebKit before 2.28.1 via crafted web content that allows remote attackers to execute arbitrary High 8.8 · Apr 17, 2020
- CVE-2020-10018 WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that mayCritical 9.8 · Mar 2, 2020
- CVE-2016-4761 WebKitGTK+ before 2.14.0: A use-after-free vulnerability can allow remote attackers to cause a DoSHigh 8.8 · Jan 22, 2020
- CVE-2019-8375 The UIProcess subsystem in WebKit, as used in WebKitGTK through 2.23.90 and WebKitGTK+ through 2.22.6 and other products, does not prevent the script dialog sizCritical 9.8 · Feb 24, 2019
- CVE-2018-12911 WebKitGTK+ 2.20.3 has an off-by-one error, with a resultant out-of-bounds write, in the get_simple_globs functions in ThirdParty/xdgmime/src/xdgmimecache.c and Critical 9.8 · Jul 19, 2018
- CVE-2018-11712 WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp in the libsoup network backend of WebKit, as used in WebKitGTK+ versions 2.20.0 and 2.20.1, failed High 7.5 · Jun 4, 2018
- CVE-2018-11646 webkitFaviconDatabaseSetIconForPageURL and webkitFaviconDatabaseSetIconURLForPageURL in UIProcess/API/glib/WebKitFaviconDatabase.cpp in WebKit, as used in WebKiHigh 7.5 · Jun 1, 2018
- CVE-2017-1000121 The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate message size metadata, allowing a compromised secondary process tCritical 9.8 · Nov 1, 2017
- CVE-2015-2330 Late TLS certificate verification in WebKitGTK+ prior to 2.6.6 allows remote attackers to view a secure HTTP request, including, for example, secure cookies.High 7.5 · Mar 9, 2017
Part of our vulnerability database: the whole National Vulnerability Database plus CISA’s exploited list, refreshed twice a day. This is general guidance, not a review of your systems.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.