Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,525 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?Ultimate Addons for WPBakeryWPBakery Page Builder Addons by LivemeshWPBakery Visual ComposerWPBakery Page BuilderTheGem Theme Elements (for WPBakery)Web and WooCommerce Addons for WPBakery BuilderExtensive VC Addons for WPBakery page builderPricing Tables For WPBakery Page Builder (formerly Visual Composer)
Plugin · js_composer
WPBakery Page Builder
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Sep 1, 2026WPBakery Page Builder: Stored Cross-Site ScriptingCVE-2026-15101 · affects up to 8.7.4 · reported by WordfenceMedium 6.4
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data' parameter in all versions up to, and including, 8.7.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The wp_kses_post sanitization applied during save does not neutralize the payload because the malicious script content is base64-encoded as plain alphanumeric text with no HTML tags to strip; the vc_raw_html shortcode template then decodes and echoes this content unescaped at render time.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jun 17, 2026Subscriber Broken Access Control in WPBakery Page Builder <= 8.7.2 versions.CVE-2026-45436 · affects up to 8.7.2 · reported by PatchstackMedium 6.5
Subscriber Broken Access Control in WPBakery Page Builder <= 8.7.2 versions.
Oct 18, 2025WPBakery Page Builder: Stored Cross-Site ScriptingCVE-2025-10006 · affects up to 8.6 · reported by WordfenceMedium 6.4
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'rev_slider_vc' shortcode in all versions up to, and including, 8.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when RevSlider is also installed.
Oct 15, 2025WPBakery Page Builder: Stored Cross-Site ScriptingCVE-2025-11161 · affects up to 8.6.1 · reported by WordfenceMedium 6.4
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the vc_custom_heading shortcode in all versions up to, and including, 8.6.1. This is due to insufficient restriction of allowed HTML tags and improper sanitization of user-supplied attributes in the font_container parameter. This makes it possible for authenticated attackers with contributor-level access or higher to inject arbitrary web scripts in posts that will execute whenever a user accesses an injected page via the vc_custom_heading shortcode with malicious tag and text attributes granted they have access to use WPBakery shortcodes.
Oct 15, 2025WPBakery Page Builder: Stored Cross-Site ScriptingCVE-2025-11160 · affects up to 8.6.1 · reported by WordfenceMedium 6.4
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS module in all versions up to, and including, 8.6.1. This is due to insufficient input sanitization and output escaping of user-supplied JavaScript code in the Custom JS module. This makes it possible for authenticated attackers with contributor-level access or higher to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page via the WPBakery Page Builder Custom JS module granted they have access to the WPBakery editor for post types.
Jun 22, 2023Auth.CVE-2023-31213 · fixed in 6.13.0 · reported by PatchstackMedium 6.5
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in WPBakery Page Builder plugin <= 6.13.0 versions.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.