Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,714 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · post-views-counter
Post Views Counter
2 known vulnerabilities on record. Add your version above to see which ones affect you.
Apr 12, 2024Unauthenticated Cross Site Request Forgery (CSRF) in Post Views Counter <= 1.4.4 versions.CVE-2024-31264 · affects up to 1.4.4 · reported by PatchstackMedium 4.3
Unauthenticated Cross Site Request Forgery (CSRF) in Post Views Counter <= 1.4.4 versions.
Sep 20, 2021Post Views Counter: Does not sanitise or escape its Post Views Label settingsCVE-2021-24613 · fixed in 1.3.5 · reported by WPScanMedium 4.8
The Post Views Counter WordPress plugin before 1.3.5 does not sanitise or escape its Post Views Label settings, which could allow high privilege users to perform Cross-Site Scripting attacks in the frontend even when the unfiltered_html capability is disallowed
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.