Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,714 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?WP Go MapsMapSVGWP MapsMapPress Maps forMapSVGgoogle-maps-easyultimate-maps-by-supsysticmapster-wp-maps

Plugin · google-maps-easy

google-maps-easy

10 known vulnerabilities on record. Add your version above to see which ones affect you.

Is google-maps-easy safe? The full page →

  • Sep 30, 2026Unauthenticated Cross Site Scripting (XSS) in Easy Google Maps <= 1.14.6 versions.CVE-2026-102395 · affects up to 1.14.6 · reported by PatchstackHigh 7.1

    Unauthenticated Cross Site Scripting (XSS) in Easy Google Maps <= 1.14.6 versions.

  • Aug 18, 2026Unauthenticated Remote File Inclusion in Easy Google Maps < 1.14.2 versions.CVE-2026-73367 · reported by PatchstackHigh 7.2

    Unauthenticated Remote File Inclusion in Easy Google Maps < 1.14.2 versions.

  • Aug 18, 2026Unauthenticated PHP Object Injection in Easy Google Maps <= 1.13.0 versions.CVE-2026-73366 · affects up to 1.13.0 · reported by PatchstackCritical 9.8

    Unauthenticated PHP Object Injection in Easy Google Maps <= 1.13.0 versions.

  • Apr 4, 2025Easy Google Maps: Improper Restriction of XML External Entity ReferenceCVE-2025-32138 · affects up to 1.11.18 · reported by PatchstackMedium 6.6

    Improper Restriction of XML External Entity Reference vulnerability in supsystic Easy Google Maps google-maps-easy allows XML Injection.This issue affects Easy Google Maps: from n/a through <= 1.11.18.

  • Jul 2, 2024Easy Google Maps: Stored Cross-Site ScriptingCVE-2024-5219 · affects up to 1.11.15 · reported by WordfenceMedium 6.4

    The Easy Google Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file upload feature in all versions up to, and including, 1.11.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Apr 12, 2024Easy Google Maps: Cross-Site Request Forgery (CSRF)CVE-2024-31269 · affects up to 1.11.11 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Easy Google Maps.This issue affects Easy Google Maps: from n/a through 1.11.11.

  • Jun 9, 2023Easy Google Maps: Cross-Site Request ForgeryCVE-2023-2526 · affects up to 1.11.7 · reported by WordfenceMedium 5.4

    The Easy Google Maps plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.11.7. This is due to missing or incorrect nonce validation on the AJAX action handler. This makes it possible for unauthenticated attackers to executes AJAX actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. CVE-2024-31269 appears to be a duplicate of this issue.

  • May 28, 2023Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Easy Google Maps plugin <= 1.11.7 versions.CVE-2023-33926 · fixed in 1.11.8 · reported by PatchstackHigh 7.1

    Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Easy Google Maps plugin <= 1.11.7 versions.

  • Apr 25, 2022Easy Google Maps: Does not escape the tab parameter before outputting it back in an attribute in the admin dashboardCVE-2021-46780 · fixed in 1.9.32 · reported by WPScanMedium 6.1

    The Easy Google Maps WordPress plugin before 1.9.32 does not escape the tab parameter before outputting it back in an attribute in the admin dashboard, leading to a Reflected Cross-Site Scripting

  • Nov 1, 2021Google Maps Easy: Stored Cross-Site ScriptingCVE-2021-39346 · affects up to 1.9.33 · reported by WordfenceMedium 4.8

    The Google Maps Easy WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.9.33. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.