Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
CriticalCVSS v3.1 9.3Fixed in the July 2026 patches

If your online store runs Magento, the July security patch is no longer optional

CVE-2026-48356 lets an attacker upload a dangerous file to an Adobe Commerce or Magento Open Source store and run code with it. Adobe fixed it in July. On October 27, CISA added it to its list of flaws attackers are actively using, which means stores that skipped the July patch are now being hit.

Nikita HuttenlocherFounder and lead engineer, Huttenlocher Technologies
Published October 28, 20263 min read
Update: Ask your developer or host which Magento version and patch level your store runs, and whether the July 2026 patch is installed.

What it is

In Adobe’s words, the flaw is an “Unrestricted Upload of File with Dangerous Type vulnerability that could result in arbitrary code execution.” Put simply: the store accepts a file it should refuse, and that file can then run as code. Adobe notes the attack needs a person to visit a crafted link or a compromised page, which on a busy store is a low bar.

Adobe published the fix on July 14, 2026 in bulletin APSB26-73. The reason it matters again now is that CISA added it to its exploited list on October 27, so this has moved from “a patch you should install” to “a patch attackers are checking for.”

Which stores are affected

  • Magento Open Source 2.4.9, 2.4.8-p5, 2.4.7-p10, 2.4.6-p15 and every earlier release in those lines.
  • Adobe Commerce 2.4.9, 2.4.8-p5, 2.4.7-p10, 2.4.6-p15, 2.4.5-p17, 2.4.4-p18 and earlier, plus Adobe Commerce B2B 1.5.3 and earlier.
  • Adobe Commerce Events 1.20.0 and earlier (fixed in 1.21.0).
  • Release lines missing from Adobe’s fixed list (Magento Open Source before 2.4.6, Adobe Commerce before 2.4.4) have no listed fix. If your store is that far behind, the patch question is really a replatform question.

What to do

  1. Find your versionYour developer or host can tell you in a minute. In the admin, the version shows at the bottom of every page.
  2. Install the July 2026 patchThe fixed builds carry “2026-jul” in the version (for example 2.4.8-2026-jul). Patch a copy of the store first if you can, then the live store.
  3. Look for signs it already happenedThe flaw was exploited before many stores patched. Ask whoever runs the server to check for files in the media and upload folders that shouldn’t be there, and for admin accounts nobody recognizes.
  4. If nobody maintains the storeThat’s the real risk. A Magento store needs someone applying Adobe’s patches every quarter, or it should move to a platform that patches itself.

We build and look after online stores that don’t depend on quarterly patch cycles. If you’d like a second opinion on yours, tell us about it.

Written by Nikita Huttenlocher, founder and lead engineer at Huttenlocher Technologies, a cybersecurity and software firm in Myrtle Beach, South Carolina. This is general guidance, not a review of your systems.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.